Консультант по 1С в Крыму. +7(978)857-2035

Помогу с 1С!

программист 1С Симферополь

Позвоните:
+7(978)857-2035

Управление MS Outlook из 1С

/ Просмотров: 24260

//создать новое сообщение из 1С в MS Outlook

Процедура Письмо_Создать()

     //приложение

     Попытка

          Оле=CreateObject("Outlook.Application");

          ЕстьОшибка=0;

     Исключение

          Предупреждение("Не удалось создать письмо в MS Outlook!");

          ЕстьОшибка=1;

     КонецПопытки;

     //адрес

     Адрес=СокрЛП(Лицо.АдресЭ);

     //письмо

     Если ЕстьОшибка=0 Тогда

          //Outlook

          Письмо=Оле.CreateItem(0);

          Письмо.Subject=Клиент.Наименование+?(Лицо.Выбран()=0,"",", "+Лицо.Наименование);

          Письмо.Body=гЛицо(Лицо);

          Если ПустаяСтрока(Адрес)=0 Тогда

               Письмо.Recipients.Add(Адрес);

          КонецЕсли;

          Если ПустаяСтрока(Путь)=0 Тогда

               Письмо.Attachments.Add(Путь);

          КонецЕсли;

          Письмо.Display();

     Иначе

          //тема

          Тема=Клиент.Наименование;

          Если Лицо.Выбран()=1 Тогда

               Тема=Тема+", "+Лицо.Наименование+"&body="+СокрЛП(Лицо.Имя);

          КонецЕсли;

          ЗапуститьПриложение("mailto:"+Адрес+"?subject="+Тема);

     КонецЕсли;

КонецПроцедуры

//создать запись в календаре событий

Процедура Календарь_Создать()

     //приложение

     Попытка

          Оле=CreateObject("Outlook.Application");

     Исключение

          Предупреждение("Не удалось создать запись в календаре событий в MS Outlook!");

          Возврат;

     КонецПопытки;

     //задача

     Задача=Оле.CreateItem(1);

     Задача.Subject="Название встречи";

     Задача.Start="01.11.2007 15:00:00";

     Задача.End="01.11.2007 16:00:00";

     Задача.Body="Описание встречи";

     Задача.Location="Место встречи";

     Задача.ReminderMinutesBeforeStart=30;

     Задача.BusyStatus=0;

     Задача.MeetingStatus=0;

     Задача.Sensitivity=2;

     Задача.Save();

КонецПроцедуры

//создать новую задачу из 1С в MS Outlook

Процедура Задача_Создать()

     //приложение     Попытка

          Оле=CreateObject("Outlook.Application");

     Исключение

          Предупреждение("Не удалось создать задачу в MS Outlook!");

          Возврат;

     КонецПопытки;

     //задача     Задача=Оле.CreateItem(3);

     Задача.Subject=Клиент.Наименование;

     Задача.StartDate=ДатаДок+Константа.Фирма.ПериодСобытие;

     Задача.Display();

     Если Лицо.Выбран()=1 Тогда

          Задача.Body=

          ""+Лицо.Наименование+"

          |"+гЛицо(Лицо)+"

          |"+СокрЛП(Лицо.Должность)+"

          |моб. "+СокрЛП(Лицо.ТелефонМ)+"

          |гор. "+СокрЛП(Лицо.ТелефонГ);

     КонецЕсли;

КонецПроцедуры

Комментариев: 2 RSS
Александр2
2010-05-17 в 17:35:26

странно....зачем ОЛЕ ? Например,с БАТом достаточно ОДНОЙ комманды,это раз, во-вторых, что аутглюк,что экспресс не умеет атачить файлы с коммандной строки...А это просто бесит...Вот,кому может нужно, нате пример:

ЗапуститьПриложение("C:\Program Files\The Bat!\thebat.exe /MAILTo='КОМУ@что-то.где-то';SUBJECT="+СокрЛП(Лев(ИмяКомпьютера(),10))+ДатаОтчета+"-"+ОбщСум+";ATTACH="+СокрЛП(Константа.ПутьПослОтчета)+"\что-то_для_атача.txt");

обратите внимание на ОДИНАРНЫЕ кавычки. Всем удачи ;)

Оставьте комментарий!

grin LOL cheese smile wink smirk rolleyes confused surprised big surprise tongue laugh tongue rolleye tongue wink raspberry blank stare long face ohh grrr gulp oh oh downer red face sick shut eye hmmm mad angry zipper kiss shock cool smile cool smirk cool grin cool hmm cool mad cool cheese vampire snake excaim question

Используйте нормальные имена. Ваш комментарий будет опубликован после проверки.

Вы можете войти под своим логином или зарегистрироваться на сайте.

(обязательно)