Консультант по 1С в Крыму. +7(978)857-2035

Помогу с 1С!

программист 1С Симферополь

Позвоните:
+7(978)857-2035

Операции с файловой системой из 1С

/ Просмотров: 10297

//открытие файла заданного типаФункция гФайл_Открыть(Файл,Каталог,ФлагВсе,ФлагТекст=0,ФлагКнига=0,ФлагДокумент=0,ФлагПрезентация=0,ФлагАкробат=0) Экспорт

     //меню     Если ПустоеЗначение(Файл)=0 Тогда

          А=СоздатьОбъект("СписокЗначений");

          А.ДобавитьЗначение(0,"Открыть");

          А.ДобавитьЗначение(1,"Выбрать");

          Ответ=0;

          Если А.ВыбратьЗначение(Ответ,,,,1)=0 Тогда

               Возврат(0);

          ИначеЕсли Ответ=0 Тогда

               ЗапуститьПриложение(Каталог+Файл);

               Возврат(0);

          ИначеЕсли Ответ=1 Тогда

               ФС.УстТекКаталог(Каталог);

          КонецЕсли;

     КонецЕсли;

     //формат     Список="";

     Если ФлагВсе=1 Тогда

          Список=Список+"|Все файлы|*.*";     КонецЕсли;

     Если ФлагТекст=1 Тогда

          Список=Список+"|Текстовые файлы|*.txt";

     КонецЕсли;

     Если ФлагКнига=1 Тогда

          Список=Список+"|Книги MS Excel|*.xls";

     КонецЕсли;

     Если ФлагДокумент=1 Тогда

          Список=Список+"|Документы MS Word|*.doc";

     КонецЕсли;

     Если ФлагПрезентация=1 Тогда

          Список=Список+"|Презентации MS PowerPoint|*.pps";

     КонецЕсли;

     Если ФлагАкробат=1 Тогда

          Список=Список+"|Документы Adobe Acrobat|*.pdf";

     КонецЕсли;

     Список=Сред(Список,2);

     //     Возврат ФС.ВыбратьФайл(0,Файл,Каталог,"Открыть файл",Список);

КонецФункции

//процедура определяет название файла и каталога на основании заданной адресной строкиПроцедура гПуть_Получить(Путь,Файл,Каталог) Экспорт

     Текст=СтрЗаменить(Путь,"\",РазделительСтрок);

     //каталог     Для i=1 По СтрКоличествоСтрок(Текст-1) Цикл

          Каталог=Каталог+СтрПолучитьСтроку(Текст,i)+"\";

     КонецЦикла;

     //файл     Файл=СтрПолучитьСтроку(Текст,СтрКоличествоСтрок(Текст));

КонецПроцедуры

Оставьте комментарий!

grin LOL cheese smile wink smirk rolleyes confused surprised big surprise tongue laugh tongue rolleye tongue wink raspberry blank stare long face ohh grrr gulp oh oh downer red face sick shut eye hmmm mad angry zipper kiss shock cool smile cool smirk cool grin cool hmm cool mad cool cheese vampire snake excaim question

Используйте нормальные имена. Ваш комментарий будет опубликован после проверки.

Вы можете войти под своим логином или зарегистрироваться на сайте.

(обязательно)