Консультант по 1С в Крыму. +7(978)857-2035

Помогу с 1С!

программист 1С Симферополь

Позвоните:
+7(978)857-2035

Экспорт данных из 1С в файл dBase формата DBF

/ Просмотров: 16877

//процедура записывает данные об использовании отчёта в файл dBase формата DBF

Процедура гЗаписатьСтатистикуИспользованияОтчета(ИдентификаторОтчета) Экспорт

     //путь к файлу; имя файла не должно превышать 8 знаков

     Путь=КаталогИБ()+"Stat.dbf";

     //создание нового файла

     Б=СоздатьОбъект("XBase");

     Если ФС.СуществуетФайл(Путь)=0 Тогда

          //добавление полей

          Б.ДобавитьПоле("REPORT","S",100,0);

          Б.ДобавитьПоле("USER","S",50,0);

          Б.ДобавитьПоле("DATE","D",10,0);

          Б.ДобавитьПоле("TIME","S",5,0);

          //создание файла

          Б.СоздатьФайл(Путь);

          Б.ЗакрытьФайл();

     КонецЕсли;

     //открытие файла

     Б.ОткрытьФайл(Путь);

     Если Б.Открыта()=0 Тогда

          Сообщить("Не удалось открыть файл DBF","!");

          Возврат;

     КонецЕсли;

     //добавление записи

     Б.Добавить();

     Б.Date=ТекущаяДата();

     Б.Time=ТекущееВремя();

     Б.Report=СокрЛП(ИдентификаторОтчета);

     Б.User=гПользователь.Наименование;

     Б.Записать();

     //закрытие файла

     Б.ЗакрытьФайл();

КонецПроцедуры

Комментариев: 1 RSS

Подскажите, плиз! Существует готовый файл .DBF с готовыми полями, половина из которых заполнена. Задача (к примеру): Найти в файле (заполненные) поля FAM, IMJA, OTCH сравнить с сотрудниками в 1C и при соответствии заполнить поле GODROZHD в соответствующие строчки год рождения.

Оставьте комментарий!

grin LOL cheese smile wink smirk rolleyes confused surprised big surprise tongue laugh tongue rolleye tongue wink raspberry blank stare long face ohh grrr gulp oh oh downer red face sick shut eye hmmm mad angry zipper kiss shock cool smile cool smirk cool grin cool hmm cool mad cool cheese vampire snake excaim question

Используйте нормальные имена. Ваш комментарий будет опубликован после проверки.

Вы можете войти под своим логином или зарегистрироваться на сайте.

(обязательно)