Консультант по 1С в Крыму. +7(978)857-2035

Помогу с 1С!

программист 1С Симферополь

Позвоните:
+7(978)857-2035

Внешние компоненты для 1С

/ Просмотров: 13074

В своей работе с программой "1С:Предприятие" я руководствуюсь правилом "в 1С можно сделать всё". И хотя за много лет работы программистом 1С я не раз уже убеждался в существовании заказчиков, пожелания которых программа "1С:Предприятие" выполнить не в состоянии, тем не менее, вера в правильность вышеназванного правила и, в какой-то мере, выдавание желаемого за действительное позволяют мне творить чудеса.

Если серьёзно, то, действительно, программа "1С:Предприятие" имеет функционал, который, с одной стороны, достаточно мощный, но, с другой стороны, ограничен в силу специфики программы. И иногда требуется в рамках программы "1С:Предприятие" решить отдельную прикладную задачу, а функционала программы не хватает. В таких случаях на помощь программисту приходят внешние компоненты.

 

Пускай даже большинство внешних компонент пишутся сторонними разработчиками, а не самой фирмой "1С", но при использовании внешних компонент программист не выходит за рамки программы "1С:Предприятие", а потому правило "в 1С можно сделать всё" выполняется, и все остаются

довольны.

 

За весь период работы с программой "1С:Предприятие" я перепробовал множество внешних компонент. Некоторые из них я изучал с целью решения конкретных задач и потребностей моих заказчиков, а некоторые внешние компоненты мне было интересно изучить исключительно ради профессионального интереса.

 

На сегодняшний день я в своей работе использую такие внешние компоненты:

  • V7Plus
  • XMLParser
  • V7Mail
  • ROM-Mail 

Список используемых мной внешних компонент не большой, согласен. Но в вопросе использования внешних компонент для работы в программе "1С:Предприятие" я руководствуюсь принципиальным условием минимально использовать внешние компоненты. Пока получается.

 

Возможно, у Вас уже возник вопрос о том, почему я заявляю, что стараюсь придерживаться принципа не использовать внешние компоненты при работе с программой "1С:Предприятие", но при этом внешние компоненты всё-таки использую. Ответ прост. Использование внешних компонент в программе "1С:Предприятие" даёт преимущества как для пользователя, так и дополнительные удобства для меня, как для программиста. И при решении отдельных прикладных задач, стараясь найти золотую середину между убеждениями об использовании и отказе от использования внешних компонент в программе "1С:Предприятие", я использую внешние компоненты для целей, которые будут описаны ниже.

А пока я хочу напомнить, каким образом происходит загрузка внешней компоненты. Ниже Вы видите код, в котором демонстрируется метод загрузки внешней компоненты в модуле программы "1С:Предприятие".

 

//функция загружает внешнюю компоненту

//в качестве аргумента "Значение" в функцию передаётся имя файла внешней компоненты

//функция возвращает "1", если загрузка выполнена успешно, или "0", если внешнюю компоненту загрузить не получилось

Функция гВнешняяКомпонента_Загрузить(Значение) Экспорт

     Состояние("Загрузка компоненты: "+Значение);

     Если ЗагрузитьВнешнююКомпоненту(Значение)=1 Тогда

          Возврат(1);

     Иначе

          Сообщить("Ошибка при загрузке компоненты: "+Значение,"!");

          Возврат(0);

     КонецЕсли;

КонецФункции

//этот код можно разместить в локальном модуле, в котором требуется использовать внешнюю компоненту

Если гВнешняяКомпонента_Загрузить("v7plus.dll")=0 Тогда

     Возврат;

КонецЕсли;

Теперь, когда мы рассмотрели метод загрузки внешней компоненты, познакомимся более близко с внешними компонентами, которые могу рекомендовать я сам.

 

Внешняя компонента V7Plus

 

Внешняя компонента V7Plus даёт программные инструменты, которые будут очень полезны программисту прирешении отдельных задач в программе

"1С:Предприятие". В частности,

  • при помощи объекта V7Mail в программе "1С:Предприятие" можно работать с электронной почтой, создавать, отправлять и принимать электронные почтовые сообщения.
  • Объект V7HttpReader предоставляет доступ к данным по протоколу HTTP. Объект V7SysInfo поможет получить системную информацию прямо из программы "1С:Предприятие".
  • Объект XMLParser с помощью базового анализатора "Microsoft XML Parser" поможет работать с документами XML
  • А объект V7TextFile предназначен для открытия текстовых файлов большого размера.

Работа с документами XML

Из всего количества объектов, которые предоставляет внешняя компонента V7Plus, я использую только объект XMLParser для работы с файлами формата XML. Возможно, существуют и другие внешние компоненты для работы с файлами XML, но, во-первых, функционала объекта XMLParser внешней компоненты V7Plus для работы с файлами XML вполне хватает, а во-вторых, внешняя компонента V7Plus разработана самой фирмой "1С", а потому вселяет достаточную долю доверия. Посмотреть примеры использования объекта XMLParser внешней компоненты V7Plus можно в статье "Экспорт и импорт данных из 1С в XML "

 

Электронная почта

Мне известно, что внешняя компонента V7Plus используется некоторыми программистами для работы в программе "1С:Предприятие" с электронной почтой. Считаю, что тема работы с электронной почтой заслуживает отдельного внимания, поэтому прошу прочитать статью "Почта в 1С ".

 

По материалам сайта love1c 1352

Оставьте комментарий!

grin LOL cheese smile wink smirk rolleyes confused surprised big surprise tongue laugh tongue rolleye tongue wink raspberry blank stare long face ohh grrr gulp oh oh downer red face sick shut eye hmmm mad angry zipper kiss shock cool smile cool smirk cool grin cool hmm cool mad cool cheese vampire snake excaim question

Используйте нормальные имена. Ваш комментарий будет опубликован после проверки.

Вы можете войти под своим логином или зарегистрироваться на сайте.

(обязательно)